pharaoh fortune slot
ExamNotes.net
Welcome, Guest. Please login or register.
November 18, 2017, 02:34:19 AM

Login with username, password and session length
* Home Help Search Login Register
+  ExamNotes.net
|-+  Cisco
| |-+  CCNP
| | |-+  OSPF Case Study - Best Practices (long)
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Print
Author Topic: OSPF Case Study - Best Practices (long)  (Read 6141 times)
firechicken
Senior Member/Citizen
Sr. Member
****
Offline Offline

Posts: 467

2


View Profile WWW
« on: December 11, 2001, 02:27:03 AM »

Hi everyone.

  I've been fighting this case study for the past six hours, with no luck.  Before I put my first through this monitor, I'd like to get some different angles from you guys.

  In my case study, there are three routers (call them Router A, B, and C).  

  Router A connects to Router B via S0/0 ports, and is Area 0 (backbone).  Router B connects to Router C via S0/1s and is in Area 2.  Area 2 is totally stubby.  

  Router C also has five Fast Ethernet interfaces (yes, I know), which I've given the IP addresses 192.168.0.33 255.255.255.224, 192.168.0.65 255.255.255.224 and so on.

  What would be the best addressing scheme for the serial interfaces on all the routers, if I must use addresses from 192.168.0.0?  

  I am also asked to summarize routes from Area 2 into Area 0, to be configured on Router B.  

  Any help greatly appreciated!
« Last Edit: December 11, 2001, 02:32:27 AM by firechicken » Logged
The Ghost
Ditmas Technologist
Sr. Member
****
Offline Offline

Posts: 352

2


View Profile WWW
« Reply #1 on: December 11, 2001, 04:44:44 AM »

Router C is also in area 2 right?

Anyway for the serial lines in ospf it is recommended to use the subnetmask of 255.255.255.252 since you only need 2 serial ip hosts and will be wasting host addresses if u choose a lower subnet mask. So according to that just choose the ip addies while keeping the summarization factor in mind.

So based onthe hosts requirements, create vlsm addresses for the serial connections and make sure the subnet mask is ...252

That would be it I guess...
Logged

sidodgers
Member
Jr. Member
**
Offline Offline

Posts: 72

0


View Profile
« Reply #2 on: December 12, 2001, 05:10:12 PM »

Quote
Originally posted by firechicken
Hi everyone.

  I've been fighting this case study for the past six hours, with no luck.  Before I put my first through this monitor, I'd like to get some different angles from you guys.

  In my case study, there are three routers (call them Router A, B, and C).  

  Router A connects to Router B via S0/0 ports, and is Area 0 (backbone).  Router B connects to Router C via S0/1s and is in Area 2.  Area 2 is totally stubby.  

  Router C also has five Fast Ethernet interfaces (yes, I know), which I've given the IP addresses 192.168.0.33 255.255.255.224, 192.168.0.65 255.255.255.224 and so on.

  What would be the best addressing scheme for the serial interfaces on all the routers, if I must use addresses from 192.168.0.0?  

  I am also asked to summarize routes from Area 2 into Area 0, to be configured on Router B.  

  Any help greatly appreciated!


If you want to summarise five /27s (160 addresses), you'll more or less need to summarise them as an entire class C, as there is no netmask which supports 160 hosts (/25 = 128 ips, /24 = 254 ips)

Router A:

int S0/0
  ip address 192.168.0.6 255.255.255.252
router ospf 1 (pid is unimportant)
  network 192.168.0.4 0.0.0.3 area 0

router B:
int S0/0
  ip address 192.168.0.5 255.255.255.252
int S0/1
  ip address 192.168.0.9 255.255.255.252
router ospf 1
  network 192.168.0.4 0.0.0.3 area 0
  network 192.168.0.8 0.0.0.3 area 2
  area 2 range 192.168.0.0 0.0.0.255
  area 2 stub no-summary

router C:
int S0/1
  ip address 192.168.0.10 255.255.255.252
int e0/0
  ip address 192.168.0.33 255.255.255.224
.
. etc
.
router ospf 1
  network 192.168.0.8 0.0.0.3 area 2
  area 2 stub

this will 'just work' because at the ABR (router B), a default route will be injected into area 2, and therefore area 2 will not only not know about the specifics of area 0's addressing, but it won't need to.  Keep in mind, also, that the route to 192.168.0/24 will not be injected back into area 2, but only into area 0, where the fact that area 2 (192.168.0.32 to 192.168.0.191) is summarised will not matter since the more believable (and more specific) connected routes will override the summary for the 192.168.0.4-11 serial interfaces.

You'll probably also need to tell IOS that the serial interfaces are point-to-point, otherwise adjacencies may not form.

HTH,

Sid Smiley
Logged
sidodgers
Member
Jr. Member
**
Offline Offline

Posts: 72

0


View Profile
« Reply #3 on: December 12, 2001, 05:16:50 PM »

Quote
Originally posted by sidodgers


SNIP

router C:
int S0/1
  ip address 192.168.0.10 255.255.255.252
int e0/0
  ip address 192.168.0.33 255.255.255.224
.
. etc
.
router ospf 1
  network 192.168.0.8 0.0.0.3 area 2
  area 2 stub



forgot the following (for router C, in the ospf bit)
 network 192.168.0.32 0.0.0.63 area 2
 network 192.168.0.64 0.0.0.63 area 2
(..etc..)

Sorry,

Sid Smiley
Logged
firechicken
Senior Member/Citizen
Sr. Member
****
Offline Offline

Posts: 467

2


View Profile WWW
« Reply #4 on: December 13, 2001, 03:26:47 AM »

Thanks Ghost and Sid for your replies.  Sid, your config is very much appreciated and I'll give it a go tomorrow (another thanks for the copy and paste-ability of your reply, too).  

  More later Smiley
Logged
dmaftei
Senior Member
Hero Member
*****
Offline Offline

Posts: 2156

1


View Profile
« Reply #5 on: December 15, 2001, 01:24:53 AM »

Quote
Originally posted by firechicken
... I'll give it a go tomorrow...

So, how did it go?
Logged

BSEE, MSCS
www.maftei.net
firechicken
Senior Member/Citizen
Sr. Member
****
Offline Offline

Posts: 467

2


View Profile WWW
« Reply #6 on: December 16, 2001, 03:20:21 AM »

It took the better part of a day, but I finally got this case study to work.  I still don't fully understand why it worked, but that will come with time and more study.

  I have the configs laying around here somewhere if anyone wants to look at them.  

  Thanks again for the help.
Logged
dmaftei
Senior Member
Hero Member
*****
Offline Offline

Posts: 2156

1


View Profile
« Reply #7 on: December 16, 2001, 11:05:36 AM »

Quote
Originally posted by firechicken
I have the configs laying around here somewhere if anyone wants to look at them.

Sure!  I would guess a lot of people want to see the configs.
Logged

BSEE, MSCS
www.maftei.net
firechicken
Senior Member/Citizen
Sr. Member
****
Offline Offline

Posts: 467

2


View Profile WWW
« Reply #8 on: December 16, 2001, 02:38:08 PM »

Here they are in their entirety.  I should mention that this case study involved more than OSPF, as you will see Smiley      

----------
  ISP Router
----------


ISP#sh ru
Building configuration...

Current configuration:
!
version 12.0
no service password-encryption
!
hostname ISP
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
ip audit po max-events 100
!
!
!
process-max-time 200
!
interface FastEthernet0/0
 ip address 200.200.100.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial0/0
 description T1
 bandwidth 1544
 ip address 200.200.2.1 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
 clockrate 56000
!
interface BRI0/0
 no ip address
 no ip directed-broadcast
 shutdown
 isdn guard-timer 0 on-expiry accept
!
interface Serial0/1
 description T3
 bandwidth 45000
 ip address 200.200.1.1 255.255.255.0
 no ip directed-broadcast
 clockrate 56000
!
router bgp 100
 no synchronization
 network 200.200.1.0
 network 200.200.2.0
 network 200.200.100.0
 neighbor 200.200.1.2 remote-as 200
 neighbor 200.200.2.2 remote-as 200
!
no ip classless
ip route 200.200.200.0 255.255.255.0 Serial0/1
no ip http server
!
!
line con 0
 logging synchronous
 transport input none
line aux 0
line vty 0 4
 login
!
!
end

----------
  Router A
----------


RouterA#sh ru
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
this router was a real pain
!
hostname RouterA
!
!
!
!
!
!
ip subnet-zero
!
ip audit notify log
ip audit po max-events 100
ip reflexive-list timeout 120
!
!
!
process-max-time 200
!
interface Loopback0
 ip address 200.200.200.1 255.255.255.0
 no ip directed-broadcast
!
interface FastEthernet0/0
 ip address 192.168.0.5 255.255.255.252
 no ip directed-broadcast
 ip nat inside
!
interface Serial0/0
 ip address 200.200.2.2 255.255.255.0
 ip access-group firewall-in in
 ip access-group firewall-out out
 no ip directed-broadcast
 ip nat outside
!
interface BRI0/0
 no ip address
 no ip directed-broadcast
 shutdown
 isdn guard-timer 0 on-expiry accept
!
interface Serial0/1
 ip address 200.200.1.2 255.255.255.0
 ip access-group firewall-in in
 ip access-group firewall-out out
 no ip directed-broadcast
 ip nat outside
!
router ospf 1
 network 192.168.0.4 0.0.0.3 area 0
 default-information originate
!
router bgp 200
 network 200.200.200.0
 neighbor 200.200.1.1 remote-as 100
 neighbor 200.200.1.1 route-map t3preference in
 neighbor 200.200.1.1 route-map t3med out
 neighbor 200.200.2.1 remote-as 100
 neighbor 200.200.2.1 route-map t3med out
!
ip nat pool natpool 200.200.2.0 200.200.2.254 netmask 255.255.255.0
ip nat inside source list 1 pool natpool overload
ip classless
ip default-network 200.200.100.0
no ip http server
!
!
ip access-list extended firewall-in
 permit tcp host 200.200.1.1 eq bgp any
 permit tcp host 200.200.2.1 eq bgp any
 permit icmp any any
 evaluate internaltraffic
ip access-list extended firewall-out
 permit ip any any reflect internaltraffic
access-list 1 permit 192.168.0.0 0.0.0.255
route-map t1med permit 10
 set metric 100
!
route-map t3med permit 10
 set metric 50
!
route-map t3preference permit 10
 set local-preference 200
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
!
no scheduler allocate
end

----------
  Router B
----------


RouterB#sh ru
are we having fun yet
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
!
!
!
!
!
memory-size iomem 10
ip subnet-zero
!
ip audit notify log
ip audit po max-events 100
!
!
!
process-max-time 200
!
interface FastEthernet0/0
 ip address 192.168.0.6 255.255.255.252
 no ip directed-broadcast
!
interface Serial0/0
 ip address 192.168.0.9 255.255.255.252
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
 clockrate 56000
!
interface Serial0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
router ospf 1
 summary-address 192.168.0.192 255.255.255.224
 network 192.168.0.4 0.0.0.3 area 0
 network 192.168.0.8 0.0.0.3 area 2
 network 192.168.0.192 0.0.0.31 area 2
 area 2 stub no-summary
!
ip classless
no ip http server
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
!
no scheduler allocate
end

----------
Router C
----------


RouterC#sh ru
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterC
!
!
!
!
!
!
ip subnet-zero
ip dhcp excluded-address 192.168.0.193
ip dhcp excluded-address 192.168.0.161
!
ip dhcp pool f0/0Pool
   network 192.168.0.192 255.255.255.224
   default-router 192.168.0.193
!
ip dhcp pool f0/1Pool
   network 192.168.0.160 255.255.255.224
   default-router 192.168.0.161
!
ip audit notify log
ip audit po max-events 100
!
!
!
process-max-time 200
!
interface FastEthernet0/0
 ip address 192.168.0.193 255.255.255.224
 no ip directed-broadcast
!
interface Serial0/0
 ip address 192.168.0.10 255.255.255.252
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
!
interface FastEthernet0/1
 ip address 192.168.0.161 255.255.255.224
 no ip directed-broadcast
 shutdown
!
interface Serial0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
router ospf 1
 network 192.168.0.8 0.0.0.3 area 2
 network 192.168.0.192 0.0.0.31 area 2
 area 2 stub
!
ip classless
no ip http server
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
!
no scheduler allocate
if you made it this far
you have more patience
than me
end
Logged
dmaftei
Senior Member
Hero Member
*****
Offline Offline

Posts: 2156

1


View Profile
« Reply #9 on: December 16, 2001, 02:54:25 PM »

Quote
Originally posted by firechicken
if you made it this far
you have more patience
than me

I made it! Smiley  I didn't try too hard to understand what I'm reading, though...  I'll save the configs and study them later.

Cheers!
Logged

BSEE, MSCS
www.maftei.net
verruckt
Junior Member

Offline Offline

Posts: 1

0


View Profile
« Reply #10 on: October 10, 2006, 09:40:18 PM »

I am trying to work through Case Study 3 and can find no resources relating to this! Can anyone help?
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.13 | SMF © 2006-2011, Simple Machines LLC Valid XHTML 1.0! Valid CSS!